Thursday, March 27, 2008 at 2:58 PM |
Today I got a call from one of my peers regarding a problem with missing LUNs.

The SAN team presented certain number of LUNs to his 3 AIX servers but all 3 had the same exact issue. All are missing 7 LUNs.

I helped out because I thought that this should be an easy one. First he told me he ran these 3 commands:
# cfgmgr
# vxdisk scandisks
# vxdctl enable


That should do it. He ran the right commands. But didn't work. So, I had to get in to the servers and look around. First, I saw some old disks from the old SHARK array which was already been disconnected. I cleared those up and re-ran those 3 commands. Still did not work.

Then, I counted all the hdisks on each HBA and compared with the hdisks listed in "vxdisk path" command. They matched. So, I thought that didn't make sense. So, I carefully reviewed the vxdisk path output and noticed that some of the devices have 4 paths and I counted 7 of those. There, I found out what the problem was. 4 paths to a LUN with only 2 HBAs active on the server. I have seen this on a Clariion but not on Symmetrix where these servers are connected to.

So, these are the steps I took to fix the problem:

1. Removed the hdisks on those 7 devices
2. Ran vxdisk scandisks ; vxdctl enable
3. Ran cfgmgr -vl fcs1 ; cfgmgr -vl fcs4
4. Ran vxdisk scandisks ; vxdctl enable

Now, how that happened, I don't know. Could be a bug in Veritas 4.0.

Here are the detailed steps:

# vxdmpadm listctlr all
CTLR-NAME ENCLR-TYPE STATE ENCLR-NAME
=====================================================
scsi0 Disk ENABLED Disk
fscsi4 EMC ENABLED EMC0
fscsi1 EMC ENABLED EMC0
fscsi4 EMC ENABLED EMC1
fscsi1 EMC ENABLED EMC1

# lscfg | grep hdisk | grep EMC | cut -d"W" -f2 | cut -d"-" -f1 | sort -u
50060482CCB501C6
50060482CCB501C9
50060482CCAB5543
50060482CCAB554C

# lscfg | grep 50060482CCB501C6 | wc -l
48

# lscfg | grep 50060482CCB501C9 | wc -l
48

# lscfg | grep 50060482CCAB5543 | wc -l
58

# lscfg | grep 50060482CCAB554C | wc -l
58

# vxdisk list | grep EMC0 | wc -l
48

# vxdisk list | grep EMC1 | wc -l
51

# vxdisk list EMC1_19 | grep hdisk
hdisk97 state=enabled
hdisk107 state=enabled
hdisk211 state=enabled
hdisk182 state=enabled

# lscfg | egrep 'hdisk97|hdisk107|hdisk211|hdisk182'
* hdisk107 U5791.001.99205GR-P2-C10-T1-W50060482CCAB5543-L92000000000000 EMC Symmetrix FCP Raid5
* hdisk211 U5791.001.99205GR-P2-C10-T1-W50060482CCAB5543-LAD000000000000 EMC Symmetrix FCP Raid5
* hdisk97 U5791.001.99205LM-P2-C03-T1-W50060482CCAB554C-L92000000000000 EMC Symmetrix FCP Raid5
* hdisk182 U5791.001.99205LM-P2-C03-T1-W50060482CCAB554C-LAD000000000000 EMC Symmetrix FCP Raid5

# for i in 19 20 21 22 23 24 25
do
vxdisk list EMC1_$i | grep hdisk | awk '{ print $1 }'
done | while read disk
do
rmdev -dl $disk
done

# vxdisk scandisks ; vxdctl enable

# cfgmgr -vl fcs1; cfgmgr -vl fcs4

# vxdisk scandisks ; vxdctl enable

# vxdisk list | grep EMC1 | wc -l
58

# vxdisk list EMC1_19 | grep hdisk
hdisk107 state=enabled
hdisk211 state=enabled
Posted by JAUGHN Labels:

0 comments:

Visit the Site
MARVEL and SPIDER-MAN: TM & 2007 Marvel Characters, Inc. Motion Picture © 2007 Columbia Pictures Industries, Inc. All Rights Reserved. 2007 Sony Pictures Digital Inc. All rights reserved. blogger template by blog forum